$re = '/(?<!\\\\)(?:\\\\{2})*(?:"[^\\\\"]*(?:\\\\.[^"\\\\]*)*"|\'[^\\\\\']*(?:\\\\.[^\'\\\\]*)*\')(*SKIP)(*F)|\h+/m';
$str = '2 + 2
2+2
f( " ")
f(" ")
f("Test \\"mystring\\" .")
f("Test \\"mystring\\" .")
f("\' ", " ")
f("\' "," ")';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;