re = /(?<!\\)(?:\\{2})*(?:"[^\\"]*(?:\\.[^"\\]*)*"|'[^\\']*(?:\\.[^'\\]*)*')(*SKIP)(*F)|\h+/m
str = '2 + 2
2+2
f( " ")
f(" ")
f("Test \\"mystring\\" .")
f("Test \\"mystring\\" .")
f("\' ", " ")
f("\' "," ")'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result