use strict;
my $str = '2 + 2
2+2
f( " ")
f(" ")
f("Test \\"mystring\\" .")
f("Test \\"mystring\\" .")
f("\' ", " ")
f("\' "," ")';
my $regex = qr/(?<!\\)(?:\\{2})*(?:"[^\\"]*(?:\\.[^"\\]*)*"|'[^\\']*(?:\\.[^'\\]*)*')(*SKIP)(*F)|\h+/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";