using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^http(?:s)?:\/\/(?:[\w-]+\.?)+\/[\w-\.]+(\/[\w-])?$";
string input = @"http://my.de/site
https://another
https://another.site
https://another.site.de/site
https://another.site-s.de/site
https://another.site/de
http://foodfacts.mercola.com/green-tea.html
http://foodfacts.mercola.com/green-tea.html/ssja
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}