// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^http(?:s)?:\/\/(?:[\w-]+\.?)+\/[\w-\.]+(\/[\w-])?$").unwrap();
let string = "http://my.de/site
https://another
https://another.site
https://another.site.de/site
https://another.site-s.de/site
https://another.site/de
http://foodfacts.mercola.com/green-tea.html
http://foodfacts.mercola.com/green-tea.html/ssja
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}