const regex = /^http(?:s)?:\/\/(?:[\w-]+\.?)+\/[\w-\.]+(\/[\w-])?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^http(?:s)?:\\\/\\\/(?:[\\w-]+\\.?)+\\\/[\\w-\\.]+(\\\/[\\w-])?$', 'gm')
const str = `http://my.de/site
https://another
https://another.site
https://another.site.de/site
https://another.site-s.de/site
https://another.site/de
http://foodfacts.mercola.com/green-tea.html
http://foodfacts.mercola.com/green-tea.html/ssja
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}