import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^http(?:s)?:\\/\\/(?:[\\w-]+\\.?)+\\/[\\w-\\.]+(\\/[\\w-])?$";
final String string = "http://my.de/site\n"
+ "https://another\n"
+ "https://another.site\n"
+ "https://another.site.de/site\n"
+ "https://another.site-s.de/site\n"
+ "https://another.site/de\n"
+ "http://foodfacts.mercola.com/green-tea.html\n"
+ "http://foodfacts.mercola.com/green-tea.html/ssja\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}