using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"({{TICKETS}}.*?{{\/TICKETS}})";
string substitution = @"<div class=""ticket"">x</div>";
string input = @"<body>
{{TICKETS}}
<div class=""ticket"">{{asd}}</div>
{{/TICKETS}}
{{TICKETS}}
</body>";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase | RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}