re = /({{TICKETS}}.*?{{\/TICKETS}})/mi
str = '<body>
{{TICKETS}}
<div class="ticket">{{asd}}</div>
{{/TICKETS}}
{{TICKETS}}
</body>'
subst = '<div class="ticket">x</div>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result