const regex = /({{TICKETS}}.*?{{\/TICKETS}})/misg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('({{TICKETS}}.*?{{\\\/TICKETS}})', 'misg')
const str = `<body>
{{TICKETS}}
<div class="ticket">{{asd}}</div>
{{/TICKETS}}
{{TICKETS}}
</body>`;
const subst = `<div class="ticket">x</div>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);