import Foundation
let pattern = #"({{TICKETS}}.*?{{\/TICKETS}})"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive, .dotMatchesLineSeparators])
let testString = #"""
<body>
{{TICKETS}}
<div class="ticket">{{asd}}</div>
{{/TICKETS}}
{{TICKETS}}
</body>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<div class="ticket">x</div>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)