# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([#@])|[\p{P}\p{S}\d]/$1/g;t' <<< "^Hello, my #friend @Даниил%% 中英 字 典!!."