use strict;
my $str = '^Hello, my #friend @Даниил%% 中英 字 典!!.';
my $regex = qr`([#@])|[\p{P}\p{S}\d]`p;
my $subst = '$1';
my $result = $str =~ s`$regex`$subst`rg;
print "The result of the substitution is' $result\n";