#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "([#@])|[\p{P}\p{S}\d]"
Local $sString = "^Hello, my #friend @Даниил%% 中英 字 典!!."
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)