re = /([#@])|[\p{P}\p{S}\d]/
str = '^Hello, my #friend @Даниил%% 中英 字 典!!.'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result