using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([#@])|[\p{P}\p{S}\d]";
string substitution = @"$1";
string input = @"^Hello, my #friend @Даниил%% 中英 字 典!!.";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}