$re = '`([#@])|[\p{P}\p{S}\d]`';
$str = '^Hello, my #friend @Даниил%% 中英 字 典!!.';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;