package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([#@])|[\p{P}\p{S}\d]`)
var str = `^Hello, my #friend @Даниил%% 中英 字 典!!.`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}