#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<one>\d+-\d+)\s*(?<two>\w+)\s*:\s*(?<three>\w+)"
Local $sString = "9-11 w: wwtxmsjwjwlw" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"5-6 g: wggghg"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")