const regex = /(?<one>\d+-\d+)\s*(?<two>\w+)\s*:\s*(?<three>\w+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<one>\\d+-\\d+)\\s*(?<two>\\w+)\\s*:\\s*(?<three>\\w+)', 'gm')
const str = `9-11 w: wwtxmsjwjwlw
5-6 g: wggghg`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}