using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<one>\d+-\d+)\s*(?<two>\w+)\s*:\s*(?<three>\w+)";
string input = @"9-11 w: wwtxmsjwjwlw
5-6 g: wggghg";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}