// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?<one>\d+-\d+)\s*(?<two>\w+)\s*:\s*(?<three>\w+)").unwrap();
let string = "9-11 w: wwtxmsjwjwlw
5-6 g: wggghg";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}