$re = '/(?<one>\d+-\d+)\s*(?<two>\w+)\s*:\s*(?<three>\w+)/m';
$str = '9-11 w: wwtxmsjwjwlw
5-6 g: wggghg';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);