import re
regex = re.compile(r"(?<one>\d+-\d+)\s*(?<two>\w+)\s*:\s*(?<three>\w+)", flags=re.MULTILINE)
test_str = ("9-11 w: wwtxmsjwjwlw\n\n\n"
"5-6 g: wggghg")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")