re = /(?<one>\d+-\d+)\s*(?<two>\w+)\s*:\s*(?<three>\w+)/m
str = '9-11 w: wwtxmsjwjwlw
5-6 g: wggghg'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end