# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[^ 0-9a-zA-Z](?!(?<=\d\.)\d)//gm;t' <<< "What? The Census Says It’s Counted 99.9 Percent of Households. Don’t Be Fooled."