#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)[^ 0-9a-zA-Z](?!(?<=\d\.)\d)"
Local $sString = "What? The Census Says It’s Counted 99.9 Percent of Households. Don’t Be Fooled."
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)