# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[^ 0-9a-zA-Z](?!(?<=\d\.)\d)"
test_str = "What? The Census Says It’s Counted 99.9 Percent of Households. Don’t Be Fooled."
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.