using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^ 0-9a-zA-Z](?!(?<=\d\.)\d)";
string substitution = @"";
string input = @"What? The Census Says It’s Counted 99.9 Percent of Households. Don’t Be Fooled.";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}