use strict;
my $str = 'What? The Census Says It’s Counted 99.9 Percent of Households. Don’t Be Fooled.';
my $regex = qr/[^ 0-9a-zA-Z](?!(?<=\d\.)\d)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";