import Foundation
let pattern = #"[^ 0-9a-zA-Z](?!(?<=\d\.)\d)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"What? The Census Says It’s Counted 99.9 Percent of Households. Don’t Be Fooled."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)