$re = '/[^ 0-9a-zA-Z](?!(?<=\d\.)\d)/m';
$str = 'What? The Census Says It’s Counted 99.9 Percent of Households. Don’t Be Fooled.';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;