#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:\b|_)(?!\d+\b|[A-Z]+\b)([A-Z\d]{10})(?:\b|_)"
Local $sString = "LEGION T5 (90SV003WGE)" & @CRLF & _
"FLEX 5 (82R700BEGE) XKLUSIV" & @CRLF & _
"V17-IRU 83A2001NGE" & @CRLF & _
"LENOVO E16 G1 21JT000HGE_WIN 11" & @CRLF & _
"LENOVO THINKCENTRE M70T 12Q6000AGE I7-12" & @CRLF & _
"IDEAPAD 3 17ALC6" & @CRLF & _
"TEST 12345ABCDE TEST ZYXWV98765"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")