import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\b|_)(?!\\d+\\b|[A-Z]+\\b)([A-Z\\d]{10})(?:\\b|_)";
final String string = "LEGION T5 (90SV003WGE)\n"
+ "FLEX 5 (82R700BEGE) XKLUSIV\n"
+ "V17-IRU 83A2001NGE\n"
+ "LENOVO E16 G1 21JT000HGE_WIN 11\n"
+ "LENOVO THINKCENTRE M70T 12Q6000AGE I7-12\n"
+ "IDEAPAD 3 17ALC6\n"
+ "TEST 12345ABCDE TEST ZYXWV98765";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}