const regex = /(?:\b|_)(?!\d+\b|[A-Z]+\b)([A-Z\d]{10})(?:\b|_)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\b|_)(?!\\d+\\b|[A-Z]+\\b)([A-Z\\d]{10})(?:\\b|_)', 'gm')
const str = `LEGION T5 (90SV003WGE)
FLEX 5 (82R700BEGE) XKLUSIV
V17-IRU 83A2001NGE
LENOVO E16 G1 21JT000HGE_WIN 11
LENOVO THINKCENTRE M70T 12Q6000AGE I7-12
IDEAPAD 3 17ALC6
TEST 12345ABCDE TEST ZYXWV98765`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}