using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\b|_)(?!\d+\b|[A-Z]+\b)([A-Z\d]{10})(?:\b|_)";
string input = @"LEGION T5 (90SV003WGE)
FLEX 5 (82R700BEGE) XKLUSIV
V17-IRU 83A2001NGE
LENOVO E16 G1 21JT000HGE_WIN 11
LENOVO THINKCENTRE M70T 12Q6000AGE I7-12
IDEAPAD 3 17ALC6
TEST 12345ABCDE TEST ZYXWV98765";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}