import Foundation
let pattern = #"(?:\b|_)(?!\d+\b|[A-Z]+\b)([A-Z\d]{10})(?:\b|_)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
LEGION T5 (90SV003WGE)
FLEX 5 (82R700BEGE) XKLUSIV
V17-IRU 83A2001NGE
LENOVO E16 G1 21JT000HGE_WIN 11
LENOVO THINKCENTRE M70T 12Q6000AGE I7-12
IDEAPAD 3 17ALC6
TEST 12345ABCDE TEST ZYXWV98765
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)