$re = '/(?:\b|_)(?!\d+\b|[A-Z]+\b)([A-Z\d]{10})(?:\b|_)/m';
$str = 'LEGION T5 (90SV003WGE)
FLEX 5 (82R700BEGE) XKLUSIV
V17-IRU 83A2001NGE
LENOVO E16 G1 21JT000HGE_WIN 11
LENOVO THINKCENTRE M70T 12Q6000AGE I7-12
IDEAPAD 3 17ALC6
TEST 12345ABCDE TEST ZYXWV98765';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);