#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=[0-9])\s+(?=(?:st|[rn]d|th)(?: [^\W\d_]|$))"
Local $sString = "10 th elementary" & @CRLF & _
"1 st grade" & @CRLF & _
"133 rd anniversary" & @CRLF & _
"" & @CRLF & _
"abc123 th 33333 rddccc" & @CRLF & _
"10 thetree" & @CRLF & _
"20 street" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)