import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=[0-9])\\s+(?=(?:st|[rn]d|th)(?: [^\\W\\d_]|$))";
final String string = "10 th elementary\n"
+ "1 st grade\n"
+ "133 rd anniversary\n\n"
+ "abc123 th 33333 rddccc\n"
+ "10 thetree\n"
+ "20 street\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}