# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\[[^]]*\]//g;t' <<< "strings123[abc789<span>123</span>def<span>456</span>000]strings456"