const regex = new RegExp('\\[[^]]*\\]', 'g')
const str = `strings123[abc789<span>123</span>def<span>456</span>000]strings456`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);