$re = '/\[[^]]*\]/';
$str = 'strings123[abc789<span>123</span>def<span>456</span>000]strings456';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;