#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\[[^]]*\]"
Local $sString = "strings123[abc789<span>123</span>def<span>456</span>000]strings456"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)