package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[[^]]*\]`)
var str = `strings123[abc789<span>123</span>def<span>456</span>000]strings456`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}