use strict;
my $str = 'strings123[abc789<span>123</span>def<span>456</span>000]strings456';
my $regex = qr/\[[^]]*\]/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";