import re
regex = re.compile(r"\[[^]]*\]")
test_str = "strings123[abc789<span>123</span>def<span>456</span>000]strings456"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)