package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)n't|'(?:ll|[vr]e|[msd])`)
var str = `should've can't mustn't we'll`
var substitution = " \g<0>"
fmt.Println(re.ReplaceAllString(str, substitution))
}