use strict;
my $str = 'should\'ve can\'t mustn\'t we\'ll';
my $regex = qr/n't|'(?:ll|[vr]e|[msd])/mp;
my $subst = ' \\g<0>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";