import re
regex = re.compile(r"n't|'(?:ll|[vr]e|[msd])", flags=re.MULTILINE)
test_str = "should've can't mustn't we'll"
subst = " \\g<0>"
result = regex.sub(subst, test_str)
if result:
print(result)